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About the Course

e Objective
e Introduction to web programming using the Microsoft®
ASP.NET technology and Microsoft® IIS (Internet
Information Server).
e Prerequisite
* The programming language will be C#

Outline of the Course

* Introduction to web programming and ASP.NET

e Create web application using Visual Studio® 2010 and C#
e Create and add code-behind file to an ASP.NET web form
e Examine common ASP.NET Controls

e Connecting to a Database in an ASP.NET application and
ASP.NET Data Controls

e Session management
* Validation controls
e Master pages

e Configuring and deploying an ASP.NET web application on
an IS server

e Securing an ASP.NET web application
* Introduction to ASP.NET AJAX
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Server-Side Code

e What is server-side code?

e Software thatrunsonthe | rp request
server, not the client (form data, HTTP response
e Receives input from heade:-gaTtZ) HTML, XML

URL parameters
HTML form data
e Can access server-side
databases, e-mail servers,
files, mainframes, etc.
e Dynamically builds a
custom HTML response
for a client

ASP page
(static HTML,
server-side
logic)
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ASP.NET Overview and Features

e ASP.NET provides services to allow the creation,
deployment, and execution of
Web Applications and Web Services

* Web Applications are built using Web Forms

e Web Forms are designed to make building
web-based applications as easy as building Visual Basic
applications

* Built on .NET Framework: any .NET programming
language can be used (C#, Visual Basic)

e Complete object model

» Separation of code and Ul

e Maintains page state

* Session management

e Caching, Debugging, Extensibility

webTime.aspx Example h

Creating an ASP.NET Web Application using Visual Studio
Step 1: Creating the Web Application Project

e Select File > New Web Site... and choose ASP.NET Empty Web Site in
the Templates pane.

e Select File System from the drop-down list closest to Location.
e Set the Language to Visual C#, and click oK.

o
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webTime.aspx Example

e Add n ASPX file (i.e., Web Form), default named
Default.aspx is created for each new project.

¢ Visual Web Developer creates a code-behind file named
Default.aspx.cs.

* The View Designer button opens the Web Form in Design
mode.

* The Copy Web Site button allows you to copy the project’s
files to another location, such as a remote web server.

* Finally, the ASP.NET Configuration button takes you
to the Web Site Administration Tool.

e Look at Toolbox displayed in the IDE when the project loads.
e Standard and Data list of web controls.

Editing the webTime.aspx

* When the project loads for the first time, the Web Forms
Designer displays the autogenerated ASPX file in Source
mode.

* Design mode indicates the XHTML element where the cursor
is currently located.

* You can also view both the markup and the web-page design at
the same time by using Split mode

* Right click the ASPX file in the Solution Explorer
and select View Code to open the code-behind file.

12/21/2013



-

webTime.aspx Example

e Let’s create our first ASP.NET page using Visual Studio
1. Modify title of the page

Add a heading <h2>

Look at the page in Design and Split modes

Add a Label control from the Toolbox

Change ID of the Label control

Change some physical properties of the Label control

Go to webTime.aspx.cs file and add Page_Init
function to set Text property of the Label control

N o u s~ wDN

/
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webTime.aspx Example

Changing the Title of the Page

e We change the page’s title from the default Untitled Page to A Simple Web
Form Example.

e Open the ASPX file in Source mode and modify the text between the <title>
tags.

e Alternatively, you can modify the Web Form’s Title property in the
Properties window.

¢ To view the Web Form’s properties, select DOCUMENT from the drop-down
list in the Properties window.

Designing the Page

¢ To add controls to the page, you can drag and drop them from the Toolbox
onto the Web Form in Design mode.

* Like the Web Form itself, each control is an object that has properties,
methods and events.

¢ You can type text directly on a Web Form at the cursor location or insert
XHTML elements using menu commands.

/
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Renaming the WebTime.aspx

Renaming the ASPX File
 Right click the ASPX file in the Solution Explorer and select
Rename.

* Enter the new file name WebTime.aspx and press Enter. Both
the ASPX file and the code-behind file are updated.

Renaming the Class in the Code-Behind File and Updating
the ASPX File
o Visual Studio’s refactoring tool, which automatically

updates the existing references to this class in the rest of
the project to reflect this change.

o Right click the class name in the partial class’s declaration
and select Refactor > Rename... to open the Rename

N dialog. J

/Visual Studio generates the markup shown
when you create the GUI. webTime.aspx (10f2)

1 <%-- webTime.aspx --%> ASP.NET comments
2 <%-- A page that displays the current time in a Label. --%| begin with <6--and

3 <%@. Pa nguage="C#" AutoEventwireup="true" terminate with 96>,
Coéjg)l(ﬁ feg'eWe T1me.aspx. CSA and can span multiple

4 Inherits="webTime" EnableSessionState="False" %> lines.

5

6 <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//| The _Ff’_agge tfiirecti\_/e
" . _ 3 4 specifies information

; http://www.w3.org/TR/xhtm11/DTD/xhtm11-transitional.dtd needed by ASPNET

to process this file.

9 <html xmIns="http://www.w3.0rg/1999/xhtm1">

10 <head_r'unat= server”> ] 6 ST

11 <title>A Simple web Form Example</title> declaration, which specifies
12 </head> the document element name
13 <body> and the PUBLIC URI for the

. n n n_ E——— 2
14 <form id="forml" runat="server™ DTD that defines the
15 <div> XHTML vocabulary.
rent time on the we 7
16 <h2>Cur b server:</h2> T —

The form that contains our
XHTML text and controls is set
to execute on the server, which
generates equivalent XHTML.

The body contains
the main content
that the browser
displays.

have the root element
htm1 and markup
information about the
document in the head
element.

\ ASPX file that displays the web server’s time. /
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webTime.aspx

17 <p> (20f2)
18 <asp:Label ID="timeLabel" runat="server" BackColor="glack"
19 Font-Size={xx-Large" ForeColor="Yellow" ]
20 EnableviewState="False"></asp:Label>
21 </p> Teaspt " Markup for a label

, e : tag prefix
22 </div> indicates that the G50 EEL
23 </form> label is an ASP.NET

web control, not an
24 </body> XHTML element.
25 </html1>
* In an ASPX file a directive is delimited by <% @ and %>.
ASPX file that displays the web server’s time. (Part 2 of 2.)

webTime.aspx Example

* The Page directive’s Language attribute specifies the

code-behind file’s language.

* The CodeFile attribute specifies the code-behind filename.

e When AutoEventWireup is true, ASP.NET automatically treats
a method of name Page_eventName as an event handler.

e When AutoEventWireup is set to false, you specify event
handlers using attributes in the Page directive just as you

would any other web control.

* The Inherits attribute (line 4) specifies the class in the code-
behind file from which this ASP.NET class inherits.
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webTime.aspx Example

* The document type declaration, which specifies the document
element name and the PUBLIC URI for the DTD that defines
the XHTML vocabulary.

e XHTML documents have the root element html and markup
information about the document in the head element.

e Setting the runat attribute to "server" indicates that ASP.NET
processes the element and its nested elements and generates
the corresponding XHTML.

* The body contains the main content that the browser displays.

e The form that contains our XHTML text and controls is set to
execute on the server, which generates equivalent XHTML.

/

webTime.aspx Example

e The ID attribute assigns a name to a control, used as an
identifier in the code-behind file.

* The asp: tag prefix indicates that the label is an ASP.NET
web control, not an XHTML element.

e Each web control maps to a corresponding XHTML
element or group of elements.

12/21/2013
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webTime.aspx Example

* The asp:Label control is written as an XHTML span

element.

* A span element contains text with formatting styles.

* This control is processed on the server so that the
server can translate the control into XHTML.

e If this is not supported, the asp:Label element is

written as text to the client.

The code-behind file

© 0 N s WN PP
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(WebTime.aspx.cs)

// WebTime.aspx.cs
// code-behind file for a page that displays the current time.
using System;

public partial class WebTime : System.web.UI.Page
{
// initializes the contents of the page

protected void Page_Init( object sender, EventArgs e )
{

// display the server's current time in timeLabel

The Page_Init
method handles the
page’s Init event,
which indicates that
the page is ready to
be initialized.

timeLabel.Text = DateTime.Now.ToString( "hh:mm:ss" );

} // end method Page_Init
} // end class webTime

Code-behind file for a page that displays
the web server’s time. (Part 1 of 2.)

Retrieve the current
time and formats it
ashh:mm:ss.

12/21/2013
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webTime.aspx Example Run

_ré A Simple Web Form Example - Windows Inteme..‘E@g

QQ |§, http:/flocalhost:507 | "'f| X | ‘ Google
g ['_r,éASimp\eWebForm Exa... l_ - =

Current time on the web server:

03:

& Internet | Protected Mode: On H100% -

* The Page_Init method handles the page’s Init event,
which indicates that the page is ready to be initialized.

webTime.aspx Example
Relationship Between an ASPX File and a
Code Behind File

* The code-behind file inherits from Page, which defines the
general functionality of a web page.

e The code-behind file contains a partial class.

e ASP.NET generates another partial class that defines the
remainder of that class, based on the markup in the ASPX file.

e The first time the web page is requested, this class is compiled,
and an instance is created.

e This instance represents our page—it creates the XHTML that
is sent to the client.

e Once an instance of the web page has been created, multiple
clients can use it to access the page—no recompilation is
necessary.

12/21/2013
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How the Code in an ASP.NET Web Page

Executes

e When an instance of the page is created, the Prelnit event occurs first,
invoking method Page_Prelnit, which can be used to set a page’s
theme.

*The Init event occurs next, invoking method Page Init, which is used to
initialize objects and other aspects of the page.

e Next, the Load event occurs, and the Page Load event handler

executes.
e The Init eventis raised only once (when the page is first requested).
e The Load event is raised with every request.

e The page then processes any events that are generated by the page’s
controls.

e Once a response has been generated and sent, an UnTload event
occurs, which calls Page_uUnToad, which typically releases resources
used by the page.

/

- _ ™
webTime.aspx Example

e To view the XHTML generated by ASP.NET, select View
Source from the Page menul::ese - in Internet Explorer
(or View > Page Source if you are using Firefox).

* Nonvisual form components, called hidden inputs, store
data that the user doesn’t need to see.

o Attribute method of the form element specifies the
request method (usually get or post). The action attribute
identifies the resource that will be requested when a
form is submitted.

12/21/2013
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* Figure shows the XHTML generated by ASP.NET when yeprime.htm1

a web browser requests webTime. aspx.

<!-- webTime.html -->

<!-- The XHTML generated when webTime.aspx is Toaded. -->

<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.1//EN"
"http://www.w3.org/TR/xhtm111/DTD/xhtm111.dtd">

<html xmIns="http://www.w3.0rg/1999/xhtm1">
<head>
<title>A Simple web Form Example</title>
</head>
10 <body>
11 <form method="post" action="webTime.aspx" id="forml">
12 <div>

© 0 N U~ wWN P

13 <input type="hidden" name="__VIEWSTATE" id="__VIEWSTATE" value=
14 "' /WEPDWUJODEXMDES5NZY52GQ4n4mht8D7Eqxn73tM5LDnstP1Cg==" />
15 </div>

Fig. | XHTML response when the browser
requests WebTime.aspx. (Part 1 of 2.)

(10f2)

\

of the form
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(usually get or
post). The

identifies the
resource that will

aform is
submitted.
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called hidden
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that the user
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17 <div>

18 <h2>Current time on the web server:</h2>

19 <p>

20 <span id="timeLabel" style="color:Yellow;
21 background-color:Black;font-size:Xx-Large;"
22 03:11:49

23 </span>

24 </p>

25 </div>

26 </form>

27 </body>

28 </html>

Fig. | XHTML response when the browser
requests WebTime.aspx. (Part 2 of 2.)

]

webTime.html

(20f2)

The form contains a
span element to
represent the text in
the label. Formatting
properties of
timeLabel are
converted into the
sty]e attribute of
the span element.

12/21/2013
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webTime.aspx Example

* When the form is processed on the server, the runat
attribute is removed.

* Only those elements marked in the ASPX file with

runat="server" are modified or replaced in the
generated XHTML.

/

webTime.aspx Example

e The positions of controls and other elements are relative to
the Web Form’s upper-left corner. This type of layout is known
as

e An alternate type of layout is known as ,
in which controls are located exactly where they are dropped
on the Web Form.

* You can enable absolute positioning in Design mode in the
HTML Designer > CSS Styling node of the Options dialog.

e Absolute positioning is discouraged, because pages designed
in this manner may not render correctly in different browsers
or on computers with different screen resolutions and font
sizes.

12/21/2013
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Running WebTime.aspx Example

Running the Program

* You can view the Web Form several ways.

* You can select Debug > Start Without Debugging, which
runs the application by opening it in a browser window.

* To debug your application, you can select Debug > Start
Debugging. You cannot debug a web application unless
debugging is explicitly enabled by the web.config file.

e To view a specific ASPX file, you can right click either the

Web Forms Designer or the ASPX file name and select View
In Browser.

e Finally, you can run your application by opening a browser
window and typing the web page’s URL in the Address field.

Event Handling

e GUIs are event driven.

e When the user interacts with a GUI component, the
event drives the program to perform a task.

e A method that performs a task in response to an event is
called an event handler.

16



~ Event Handling Example

(HeTTowor1d)

* Let’s create another ASP.NET page using Visual Studio
1. AddaButton anda Label control
2. To create this click event handler, double click the
Button on the Form.
The following empty event handler is declared:

4. Setthe Text property of the Labe'l control with the
current time in this function.

protected void Buttonl_Click(object sender,
EventArgs e)

{

}

T EeventHanaiing =ExXampte————————

(HeTTowor1d)
e To add an event handler, alternatively in markup
(aspx) file:
1. Addaonclick="BCl1ick" propertytothe Button
control.
2. Add a function BC11 ck to the page class in the code
behind.
o %

12/21/2013
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/ H e I I OWO I"I d Exam p I e ASP.NET comments begin with <%-- and

terminate with --%%>, and can span multiple lines.

\

</head>
<body>

<%@ Page Language="C#" AutoEventWireup="true"
CodeFile="HelloWorld.aspx.cs" Inherits="HelloWorldPag

<head runat="server">
<title>Hello World Web Form</title>

<%-- Hello World page that also displays the current time. -—-2%>

to process this file.

The Page directive
specifies information
needed by ASP.NET

<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN"
"http://www.w3.0org/TR/xhtmll/DTD/xhtmll-transitional.dtd">

XHTML documents have the

<html xmlns="http://www.w3.0rg/1999/xhtml"> | rootelement html and markup

information about the document
in the head element.

The body contains the main content
that the browser displays.

The form that contains our XHTML text
and controls is set to execute on the server,

</body> </html> button web controls.

<form id="forml" runat="server">

which generates equivalent XHTML.

<asp:Button ID="buttonClick" runat="server" Font-Size="Medium"

Width="102px" Text="Click Me" onclick="BClick" />

<br />
<asp:Label ID="labelHello" runat="server"></asp:Label>
</form> Markup for label & The asp: tag prefix indicates that the label is an

ASP.NET web control, not an XHTML element.

ASPX Code Behind File

{

labelHello.Text =

public partial class HelloWorldPage
System.Web.UI.Page

protected void BClick (object sender, EventArgs e)

"Hello World! Time is " +

DateTime.Now;

12/21/2013
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Event Handling

e By convention, C# names the event-handler method as
objectName_eventName (e.g., Buttonl_C11ck).
e Each event handler receives two parameters when it is
called:
* An object reference named sender—a reference to the
object that generated the event.
* A reference to an object of type EventArgs, which
contains additional information about the event.

/—%LWGJ—\HFGW—Q—FU—V-I—GG:FG—%41—\
Handlers

e Typically, controls can generate many different types of
events.

¢ Clicking the Events icon (the lightning-bolticon) in the
Properties window, displays all the events for the selected
control.

|Buttonl System.Web.UI.WebCorlv |

T
DataBinding
Disposed
Init

Load
PreRender
Unload

Click
Fires when the button is clicked,

12/21/2013
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Locating Event Information

* To learn about the events raised by a control, select Help >
Index.

¢ In the window, select Web Development (.NET) in the
Filtered by drop-down list and enter the name of the control’s
class in the Index window.
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ASP.NET Architecture

ASP.NET: Web Services Windows
and Web Forms Forms

ADO.NET: Data and XML

Base Classes

13IN'0IpNIS [ensiA

Programming Model

ASP.NET Object Model

* Controls are objects, available in
server-side code
* Derived from System.Web.UI.Control
* The web page is an object too
* Derived from System.Web.UI.Page
* User code executes on the web server in
page or control event handlers

12/21/2013
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Resources

http://msdn.microsoft.com/en-us/aa336522.aspx

http://www.asp.net/
http://www.aspfree.com/
http://www.devx.com/dotnet/
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